6.4.3.5 Lab – Configuring Basic EIGRP for IPv6 - Answers

Certification Answers

6.4.3.5 Lab – Configuring Basic EIGRP for IPv6 (Instructor Version)

Instructor Note: Red font color or Gray highlights indicate text that appears in the instructor copy only.

Topology

Addressing Table

Device Interface IP Address Default Gateway
R1 G0/0 2001:DB8:ACAD:A::1/64 FE80::1 link-local N/A
S0/0/0 (DCE) 2001:DB8:ACAD:12::1/64 FE80::1 link-local N/A
S0/0/1 2001:DB8:ACAD:13::1/64 FE80::1 link-local N/A
R2 G0/0 2001:DB8:ACAD:B::1/64 FE80::2 link-local N/A
S0/0/0 2001:DB8:ACAD:12::2/64 FE80::2 link-local N/A
S0/0/1 (DCE) 2001:DB8:ACAD:23::2/64 FE80::2 link-local N/A
R3 G0/0 2001:DB8:ACAD:C::1/64 FE80::3 link-local N/A
S0/0/0 (DCE) 2001:DB8:ACAD:13::3/64 FE80::3 link-local N/A
S0/0/1 2001:DB8:ACAD:23::3/64 FE80::3 link-local N/A
PC-A NIC 2001:DB8:ACAD:A::3/64 FE80::1
PC-B NIC 2001:DB8:ACAD:B::3/64 FE80::2
PC-C NIC 2001:DB8:ACAD:C::3/64 FE80::3

Objectives

  • Part 1: Build the Network and Verify Connectivity
  • Part 2: Configure EIGRP for IPv6 Routing
  • Part 3: Verify EIGRP for IPv6 Routing
  • Part 4: Configure and Verify Passive Interfaces

Background / Scenario

EIGRP for IPv6 has the same overall operation and features as EIGRP for IPv4. However, there are a few major differences between them:

  • EIGRP for IPv6 is configured directly on the router interfaces.
  • With EIGRP for IPv6, a router ID is required on each router or the routing process does not start.
  • The EIGRP for IPv6 routing process uses a shutdown feature.

In this lab, you will configure the network with EIGRP routing for IPv6. You will also assign router IDs, configure passive interfaces, verify the network is fully converged, and display routing information using CLI show commands.

Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS Release 15.2(4)M3 (universalk9 image). Other routers and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the correct interface identifiers.

Note: Make sure that the routers have been erased and have no startup configurations. If you are unsure, contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 3 Routers (Cisco 1941 with Cisco IOS Release 15.2(4)M3 universal image or comparable)
  • 3 PCs (Windows 7, Vista, or XP with terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet and serial cables as shown in the topology

Part 1: Build the Network and Verify Connectivity

In Part 1, you will set up the network topology and configure basic settings, such as the interface IP addresses, device access, and passwords.

Step 1: Cable the network as shown in the topology.
Step 2: Configure PC hosts.
Step 3: Initialize and reload the routers as necessary.
Step 4: Configure basic settings for each router.

a. Disable DNS lookup.

b. Configure IP addresses for the routers as listed in Addressing Table.

Note: Configure the FE80::x link-local address and the unicast address for each router interface.

c. Configure the device name as shown in the topology.

d. Assign cisco as the console and vty passwords.

e. Assign class as the privileged EXEC password.

f. Configure logging synchronous to prevent console and vty messages from interrupting command entry.

g. Configure a message of the day.

h. Copy the running configuration to the startup configuration.

Step 5: Verify connectivity.

The routers should be able to ping one another, and each PC should be able to ping its default gateway. The PCs will not be able to ping other PCs until EIGRP routing is configured. Verify and troubleshoot if necessary.

Part 2: Configure EIGRP for IPv6 Routing

Step 1: Enable IPv6 routing on the routers.
R1(config)# ipv6 unicast-routing
Step 2: Assign a router ID to each router.

a. To begin the EIGRP for IPv6 routing configuration process, issue the ipv6 router eigrp 1 command, where 1 is the AS number.

R1(config)# ipv6 router eigrp 1

b. EIGRP for IPv6 requires a 32-bit address for the router ID. Use the eigrp router-id command to configure the router ID in the router configuration mode.

R1(config)# ipv6 router eigrp 1
R1(config-rtr)# eigrp router-id 1.1.1.1

R2(config)# ipv6 router eigrp 1
R2(config-rtr)# eigrp router-id 2.2.2.2

R3(config)# ipv6 router eigrp 1
R3(config-rtr)# eigrp router-id 3.3.3.3
Step 3: Enable EIGRP for IPv6 routing on each router.

The IPv6 routing process is shut down by default. Issue the no shutdown command to enable EIGRP for IPv6 routing on all routers.

R1(config)# ipv6 router eigrp 1
R1(config-rtr)# no shutdown

R2(config)# ipv6 router eigrp 1
R2(config-rtr)# no shutdown

R3(config)# ipv6 router eigrp 1
R3(config-rtr)# no shutdown
Step 4: Configure EIGRP for IPv6 using AS 1 on the Serial and Gigabit Ethernet interfaces on the routers.

a. Issue the ipv6 eigrp 1 command on the interfaces that participate in the EIGRP routing process. The AS number is 1 as assigned in Step 2. The configuration for R1 is displayed below as an example.

R1(config)# interface g0/0
R1(config-if)# ipv6 eigrp 1
R1(config-if)# interface s0/0/0
R1(config-if)# ipv6 eigrp 1
R1(config-if)# interface s0/0/1
R1(config-if)# ipv6 eigrp 1

b. Assign EIGRP participating interfaces on R2 and R3. You will see neighbor adjacency messages as interfaces are added to the EIGRP routing process. The messages on R1 are displayed below as an example.

R1(config-if)#
*Apr 12 00:25:49.183: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::2 (Serial0/0/0)
is up: new adjacency
*Apr 12 00:26:15.583: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::3 (Serial0/0/1)
is up: new adjacency

What address is used to indicate the neighbor in the adjacency messages? _________________
The link-local address (FE80::x) of the neighbor’s interface, which was assigned in Part 1 Step 4.

Step 5: Verify end-to-end connectivity.

Part 3: Verify EIGRP for IPv6 Routing

Step 1: Examine the neighbor adjacencies.

On R1, issue the show ipv6 eigrp neighbors command to verify that the adjacency has been established with its neighboring routers. The link-local addresses of the neighboring routers are displayed in the adjacency table.

R1# show ipv6 eigrp neighbors  

EIGRP-IPv6 Neighbors for AS(1)  
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq  
                                                    (sec)         (ms)       Cnt Num  
1   Link-local address:     Se0/0/1                  13 00:02:42    1   100  0  7  
    FE80::3  
0   Link-local address:     Se0/0/0                  13 00:03:09   12   100  0  9  
    FE80::2
Step 2: Examine the IPv6 EIGRP routing table.

Use the show ipv6 route eigrp command to display IPv6 specific EIGRP routes on all the routers.

R1# show ipv6 route eigrp  

IPv6 Routing Table - default - 10 entries  
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route  
       B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2  
       IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external  
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect  
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2  
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2  
D   2001:DB8:ACAD:B::/64 [90/2172416]  
     via FE80::2, Serial0/0/0  
D   2001:DB8:ACAD:C::/64 [90/2172416]  
     via FE80::3, Serial0/0/1  
D   2001:DB8:ACAD:23::/64 [90/2681856]  
     via FE80::2, Serial0/0/0  
     via FE80::3, Serial0/0/1
Step 3: Examine the EIGRP topology.
R1# show ipv6 eigrp topology  

EIGRP-IPv6 Topology Table for AS(1)/ID(1.1.1.1)  
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,  
       r - reply Status, s - sia Status  
  
P 2001:DB8:ACAD:A::/64, 1 successors, FD is 28160  
        via Connected, GigabitEthernet0/0  
P 2001:DB8:ACAD:C::/64, 1 successors, FD is 2172416  
        via FE80::3 (2172416/28160), Serial0/0/1  
P 2001:DB8:ACAD:12::/64, 1 successors, FD is 2169856  
        via Connected, Serial0/0/0  
P 2001:DB8:ACAD:B::/64, 1 successors, FD is 2172416  
        via FE80::2 (2172416/28160), Serial0/0/0  
P 2001:DB8:ACAD:23::/64, 2 successors, FD is 2681856  
        via FE80::2 (2681856/2169856), Serial0/0/0  
        via FE80::3 (2681856/2169856), Serial0/0/1  
P 2001:DB8:ACAD:13::/64, 1 successors, FD is 2169856  
        via Connected, Serial0/0/1

Compare the highlighted entries to the routing table. What can you conclude from the comparison? _________________
The topology table lists all the available routes to a destination. The routing table lists the best path to a destination.

Step 4: Verify the parameters and current state of the active IPv6 routing protocol processes.

Issue the show ipv6 protocols command to verify the configured parameter. From the output, EIGRP is the configured IPv6 routing protocol with 1.1.1.1 as the router ID for R1. This routing protocol is associated with autonomous system 1 with three active interfaces: G0/0, S0/0/0, and S0/0/1.

R1# show ipv6 protocols  

IPv6 Routing Protocol is "connected"  
IPv6 Routing Protocol is "ND"  
IPv6 Routing Protocol is "eigrp 1"  
EIGRP-IPv6 Protocol for AS(1)  
  Metric weight K1=1, K2=0, K3=1, K4=0, K5=0  
  NSF-aware route hold timer is 240  
  Router-ID: 1.1.1.1  
  Topology : 0 (base)  
    Active Timer: 3 min  
    Distance: internal 90 external 170  
    Maximum path: 16  
    Maximum hopcount 100  
    Maximum metric variance 1  
  
  Interfaces:
    GigabitEthernet0/0  
    Serial0/0/0  
    Serial0/0/1  
  Redistribution:  
    None

Part 4: Configure and Verify Passive Interfaces

A passive interface does not allow outgoing and incoming routing updates over the configured interface. The passive-interface interface command causes the router to stop sending and receiving Hello packets over an interface.

Step 1: Configure interface G0/0 as passive on R1 and R2.
R1(config)# ipv6 router eigrp 1
R1(config-rtr)# passive-interface g0/0

R2(config)# ipv6 router eigrp 1
R2(config-rtr)# passive-interface g0/0
Step 2: Verify the passive interface configuration.

Issue the show ipv6 protocols command on R1 and verify that G0/0 has been configured as passive.

R1# show ipv6 protocols  

IPv6 Routing Protocol is "connected"  
IPv6 Routing Protocol is "ND"  
IPv6 Routing Protocol is "eigrp 1"  
EIGRP-IPv6 Protocol for AS(1)  
  Metric weight K1=1, K2=0, K3=1, K4=0, K5=0  
  NSF-aware route hold timer is 240  
  Router-ID: 1.1.1.1  
  Topology : 0 (base)  
    Active Timer: 3 min  
    Distance: internal 90 external 170  
    Maximum path: 16  
    Maximum hopcount 100  
    Maximum metric variance 1  
  
  Interfaces:  
    Serial0/0/0  
    Serial0/0/1  
    GigabitEthernet0/0 (passive)  
  Redistribution:  
    None
Step 3: Configure the G0/0 passive interface on R3.

If a few interfaces are configured as passive, use the passive-interface default command to configure all the interfaces on the router as passive. Use the no passive-interface interface command to allow EIGRP Hello messages in and out of the router interface.

a. Configure all interfaces as passive on R3.

R3(config)# ipv6 router eigrp 1
R3(config-rtr)# passive-interface default
R3(config-rtr)#
*Apr 13 00:07:03.267: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::1 (Serial0/0/0)
is down: interface passive
*Apr 13 00:07:03.267: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::2 (Serial0/0/1)
is down: interface passive

b. After you have issued the passive-interface default command, R3 no longer participates in the routing process. What command can you use to verify it? _________________
show ipv6 route eigrp or show ipv6 route

R3# show ipv6 route eigrp  
IPv6 Routing Table - default - 7 entries  
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route  
       B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2  
       IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external  
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect  
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2  
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

c. What command can you use to display the passive interfaces on R3? _________________
show ipv6 protocols 

R3# show ipv6 protocols  
IPv6 Routing Protocol is "connected"  
IPv6 Routing Protocol is "ND"  
IPv6 Routing Protocol is "eigrp 1"  
EIGRP-IPv6 Protocol for AS(1)  
  Metric weight K1=1, K2=0, K3=1, K4=0, K5=0  
  NSF-aware route hold timer is 240  
  Router-ID: 3.3.3.3  
  Topology : 0 (base)  
    Active Timer: 3 min  
    Distance: internal 90 external 170  
    Maximum path: 16  
    Maximum hopcount 100  
    Maximum metric variance 1  
  
  Interfaces:  
    GigabitEthernet0/0 (passive)  
    Serial0/0/0 (passive)  
    Serial0/0/1 (passive)  
  Redistribution:  
    None

d. Configure the serial interfaces to participate in the routing process.

R3(config)# ipv6 router eigrp 1
R3(config-rtr)# no passive-interface s0/0/0
R3(config-rtr)# no passive-interface s0/0/1
R3(config-rtr)#
*Apr 13 00:21:23.807: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::1 (Serial0/0/0)
is up: new adjacency
*Apr 13 00:21:25.567: %DUAL-5-NBRCHANGE: EIGRP-IPv6 1: Neighbor FE80::2 (Serial0/0/1)
is up: new adjacency

e. The neighbor relationships have been established again with R1 and R2. Verify that only G0/0 has been configured as passive. What command do you use to verify the passive interface? _________________
show ipv6 protocols

R3# show ipv6 protocols  

IPv6 Routing Protocol is "connected"  
IPv6 Routing Protocol is "ND"  
IPv6 Routing Protocol is "eigrp 1"  
EIGRP-IPv6 Protocol for AS(1)  
  Metric weight K1=1, K2=0, K3=1, K4=0, K5=0  
  NSF-aware route hold timer is 240  
  Router-ID: 3.3.3.3  
  Topology : 0 (base)  
    Active Timer: 3 min  
    Distance: internal 90 external 170  
    Maximum path: 16  
    Maximum hopcount 100  
    Maximum metric variance 1  
  
  Interfaces:  
    Serial0/0/0  
    Serial0/0/1  
    GigabitEthernet0/0 (passive)  
  Redistribution:  
    None

Reflection

  1. Where would you configure passive interfaces? Why? _________________
    Passive interfaces are usually configured on router interfaces that are not connected to other routers. Passive interfaces limit the amount of unnecessary protocol traffic in the network because no router devices are receiving the messages on the other side of the link.
  2. What are some advantages with using EIGRP as the routing protocol in your network? _________________
    EIGRP routing protocol can be used with almost any size network using IPv4 or IPv6. It also uses less CPU than other dynamic routing protocols, such as OSPF. It requires little bandwidth for routing updates.

Router Interface Summary Table

Router Interface Summary
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
1900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2801 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
2811 Fast Ethernet 0/0 (F0/0) Fast Ethernet 0/1 (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
2900 Gigabit Ethernet 0/0 (G0/0) Gigabit Ethernet 0/1 (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many interfaces the router has. There is no way to effectively list all the combinations of configurations for each router class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device. The table does not include any other type of interface, even though a specific router may contain one. An example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be used in Cisco IOS commands to represent the interface.

Device Configs

R1# show run
Building configuration...

Current configuration : 1632 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
!
!
!
!
!
ipv6 unicast-routing
ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:ACAD:A::1/64
ipv6 eigrp 1
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:ACAD:12::1/64
ipv6 eigrp 1
clock rate 128000
!
interface Serial0/0/1
no ip address
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:ACAD:13::1/64
ipv6 eigrp 1
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
ipv6 router eigrp 1
passive-interface GigabitEthernet0/0
eigrp router-id 1.1.1.1
!
!
!
!
control-plane
!
!
!
line con 0
password cisco
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input all
line vty 5 15
password cisco
login
transport input all
!
scheduler allocate 20000 1000
!
end
R2# show run
Building configuration...

Current configuration : 1633 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
!
!
!
!
!
ipv6 unicast-routing
ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:B::1/64
ipv6 eigrp 1
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:12::2/64
ipv6 eigrp 1
!
interface Serial0/0/1
no ip address
ipv6 address FE80::2 link-local
ipv6 address 2001:DB8:ACAD:23::2/64
ipv6 eigrp 1
clock rate 2000000
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
ipv6 router eigrp 1
passive-interface GigabitEthernet0/0
eigrp router-id 2.2.2.2
!
!
!
!
control-plane
!
!
!
line con 0
password cisco
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input all
line vty 5 15
password cisco
login
transport input all
!
scheduler allocate 20000 1000
!
end
R3# show run
Building configuration...

Current configuration : 1672 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
memory-size iomem 15
!
ip cef
!
!
!
!
!
!
ipv6 unicast-routing
ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:ACAD:C::1/64
ipv6 eigrp 1
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:ACAD:13::3/64
ipv6 eigrp 1
clock rate 2000000
!
interface Serial0/0/1
no ip address
ipv6 address FE80::3 link-local
ipv6 address 2001:DB8:ACAD:23::3/64
ipv6 eigrp 1
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
ipv6 router eigrp 1
passive-interface default
no passive-interface Serial0/0/0
no passive-interface Serial0/0/1
eigrp router-id 3.3.3.3
!
!
!
!
control-plane
!
!
!
line con 0
password cisco
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password cisco
login
transport input all
line vty 5 15
password cisco
login
transport input all
!
scheduler allocate 20000 1000
!
end

#buttons=(Accept !) #days=(20)

Our website uses cookies to enhance your experience. Learn More
Accept !