6.2.3.9 Lab – Troubleshooting VLAN Configurations - Answers

Certification Answers

6.2.3.9 Lab – Troubleshooting VLAN Configurations (Instructor Version – Optional Lab)

Instructor Note: Red font color or gray highlights indicate text that appears in the instructor copy only. Optional activities are designed to enhance understanding and/or to provide additional practice.

Topology

Addressing Table

Device Interface IP Address Subnet Mask Default Gateway
S1 VLAN 1 192.168.1.2 255.255.255.0 N/A
S2 VLAN 1 192.168.1.3 255.255.255.0 N/A
PC-A NIC 192.168.10.2 255.255.255.0 192.168.10.1
PC-B NIC 192.168.10.3 255.255.255.0 192.168.10.1
PC-C NIC 192.168.20.3 255.255.255.0 192.168.20.1

Switch Port Assignment Specifications

Ports Assignment Network
F0/1 802.1Q Trunk N/A
F0/6-12 VLAN 10 – Students 192.168.10.0/24
F0/13-18 VLAN 20 – Faculty 192.168.20.0/24
F0/19-24 VLAN 30 – Guest 192.168.30.0/24

Objectives

  • Part 1: Build the Network and Configure Basic Device Settings
  • Part 2: Troubleshoot VLAN 10
  • Part 3: Troubleshoot VLAN 20

Background / Scenario

VLANs provide logical segmentation within an internetwork and improve network performance by separating large broadcast domains into smaller ones. By separating hosts into different networks, VLANs can be used to control which hosts can communicate. In this lab, a school has decided to implement VLANs in order to separate traffic from different end users. The school is using 802.1Q trunking to facilitate VLAN communication between switches.

The S1 and S2 switches have been configured with VLAN and trunking information. Several errors in the configuration have resulted in connectivity issues. You have been asked to troubleshoot and correct the configuration errors and document your work.

Note: The switches used with this lab are Cisco Catalyst 2960s with Cisco IOS Release 15.0(2) (lanbasek9 image). Other switches and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in the labs.

Note: Make sure that the switches have been erased and have no startup configurations. If you are unsure, contact your instructor.

Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.

Required Resources

  • 2 Switches (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
  • 3 PCs (Windows 7, Vista, or XP with terminal emulation program, such as Tera Term)
  • Console cables to configure the Cisco IOS devices via the console ports
  • Ethernet cables as shown in the topology

Part 1: Build the Network and Configure Basic Device Settings

In Part 1, you will set up the network topology and configure the switches with some basic settings, such as passwords and IP addresses. Preset VLAN-related configurations, which contain errors, are provided for you for the initial switch configurations. You will also configure the IP settings for the PCs in the topology.

Step 1: Cable the network as shown in the topology.
Step 2: Configure PC hosts.
Step 3: Initialize and reload the switches as necessary.
Step 4: Configure basic settings for each switch.

a. Disable DNS lookup.

b. Configure the IP address according to the Addressing Table.

c. Assign cisco as the console and vty passwords and enable login for console and vty lines.

d. Assign class as the privileged EXEC password.

e. Configure logging synchronous to prevent console messages from interrupting command entry.

Step 5: Load switch configurations.

The configurations for the switches S1 and S2 are provided for you. There are errors within these configurations, and it is your job to determine the incorrect configurations and correct them.

Switch S1 Configuration:

hostname S1
vlan 10
name Students
vlan 2
!vlan 20
name Faculty
vlan 30
name Guest
interface range f0/1-24
switchport mode access
shutdown
!interface f0/1
! switchport mode trunk
! no shutdown
interface range f0/7-12
!interface range f0/6-12
switchport access vlan 10
interface range f0/13-18
switchport access vlan 2
! switchport access vlan 20
interface range f0/19-24
switchport access vlan 30
end

Switch S2 Configuration:

hostname S2
vlan 10
name Students
vlan 20
name Faculty
vlan 30
name Guest
interface f0/1
switchport mode trunk
switchport trunk allowed vlan 1,10,2,30
! switchport trunk allowed vlan 1,10,20,30
interface range f0/2-24
switchport mode access
shutdown
!interface range f0/6-12
! switchport access vlan 10
interface range f0/13-18
switchport access vlan 20
interface range f0/19-24
switchport access vlan 30
shutdown
end
Step 6: Copy the running configuration to the startup configuration.

Part 2: Troubleshoot VLAN 10

In Part 2, you must examine VLAN 10 on S1 and S2 to determine if it is configured correctly. You will troubleshoot the scenario until connectivity is established.

Step 1: Troubleshoot VLAN 10 on S1.

a. Can PC-A ping PC-B? ________
No

b. After verifying that PC-A was configured correctly, examine the S1 switch to find possible configuration errors by viewing a summary of the VLAN information. Enter the show vlan brief command.

S1# show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1   default                           active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Gi0/1, Gi0/2
2   Faculty                           active    Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18
10  Students                          active    Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                Fa0/11, Fa0/12
30  Guest                             active    Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                Fa0/23, Fa0/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

c. Are there any problems with the VLAN configuration? ____________________
Yes. The port for PC-A is not assigned to the correct VLAN. The port for F0/1 is assigned to VLAN 1; therefore, it is not acting as a trunk port.

d. Examine the switch for trunk configurations using the show interfaces trunk and the show interfaces f0/1 switchport commands.

S1# show interfaces trunk

S1# show interfaces f0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: static access
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

e. Are there any problems with the trunking configuration? ____________________
Yes. No trunk ports exist and F0/1 is configured as an access port instead of a trunk port.

f. Examine the running configuration of the switch to find possible configuration errors.

Are there any problems with the current configuration? ____________________
Yes. F0/1-5 are all configured as access ports and all ports on the switch are shutdown.

g. Correct the errors found regarding F0/1 and VLAN 10 on S1. Record the commands used in the space below. ____________________

S1(config)# interface f0/1
S1(config-if)# no shutdown
S1(config-if)# switchport mode trunk
S1(config-if)# interface f0/6
S1(config-if)# no shutdown
S1(config-if)# switchport access vlan 10

h. Verify the commands had the desired effects by issuing the appropriate show commands.

S1# show interfaces trunk

Port       Mode          Encapsulation   Status          Native vlan
Fa0/1      on            802.1q          trunking        1

Port       Vlans allowed on trunk
Fa0/1      1-4094

Port       Vlans allowed and active in management domain
Fa0/1      1-2,10,30

Port       Vlans in spanning tree forwarding state and not pruned
Fa0/1      1-2,10,30

S1# show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Gi0/1, Gi0/2
2    Faculty                          active    Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18
10   Students                         active    Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12
30   Guest                            active    Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                Fa0/23, Fa0/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

i. Can PC-A ping PC-B? ______
No

Step 2: Troubleshoot VLAN 10 on S2.

a. Using the previous commands, examine the S2 switch to find possible configuration errors. Are there any problems with the current configuration? ____________________
Yes. No ports were assigned access to VLAN 10 and ports F0/1 and F0/11 are shutdown.

S2# show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Gi0/1
                                                Gi0/2
10   Students                         active
20   Faculty                          active    Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18
30   Guest                            active    Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                Fa0/23, Fa0/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

b. Correct the errors found regarding interfaces and VLAN 10 on S2. Record the commands below. ____________________

S2(config)# interface range f0/6-12
S2(config-if-range)# switchport access vlan 10
S2(config-if-range)# interface f0/11
S2(config-if)# no shutdown

c. Can PC-A ping PC-B? ______
Yes

Part 3: Troubleshoot VLAN 20

In Part 3, you must examine VLAN 20 on S1 and S2 to determine if it is configured correctly. To verify functionality, you will reassign PC-A into VLAN 20, and then troubleshoot the scenario until connectivity is established.

Step 1: Assign PC-A to VLAN 20.

a. On PC-A, change the IP address to 192.168.20.2/24 with a default gateway of 192.168.20.1.

b. On S1, assign the port for PC-A to VLAN 20. Write the commands needed to complete the configuration. ____________________

S1(config)# interface f0/6
S1(config-if)# switchport access vlan 20

c. Verify that the port for PC-A has been assigned to VLAN 20.

S1# show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
     Gi0/1, Gi0/2
2    Faculty                          active    Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18
10   Students                         active    Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                Fa0/11, Fa0/12
20   VLAN0020                         active    Fa0/6
30   Guest                            active    Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                Fa0/23, Fa0/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

d. Can PC-A ping PC-C? _____
No

Step 2: Troubleshoot VLAN 20 on S1.

a. Using the previous commands, examine the S1 switch to find possible configuration errors.

Are there any problems with the current configuration? ____________________
Yes. VLAN 2 was created instead of VLAN 20 and ports have been assigned to VLAN 2 instead of VLAN 20.

b. Correct the errors found regarding VLAN 20.

S1(config)# interface range f0/13-18
S1(config-if-range)# switchport access vlan 20
S1(config-if-range)# exit
S1(config)# no vlan 2
S1(config)# vlan 20
S1(config-vlan)# name Faculty

c. Can PC-A ping PC-C? _____
No

Step 3: Troubleshoot VLAN 20 on S2.

a. Using the previous commands, examine the S2 switch to find possible configuration errors.

Are there any problems with the current configuration? ____________________
Yes. The trunked interface has been misconfigured to allow communication for VLAN 2 instead of VLAN 20 and port f0/18 is shutdown.

S2# show interfaces trunk

Port       Mode           Encapsulation  Status       Native vlan
Fa0/1      on             802.1q         trunking     1

Port       Vlans allowed on trunk
Fa0/1      1-2,10,30

Port       Vlans allowed and active in management domain
Fa0/1      1,10,30

Port       Vlans in spanning tree forwarding state and not pruned
Fa0/1      1,10,30

S2# show run interface f0/18
Building configuration...

Current configuration : 95 bytes
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
shutdown
end

b. Correct the errors found regarding VLAN 20. Record the commands used below. ____________________

S2(config)# interface f0/18
S2(config-if)# no shutdown
S2(config)# interface f0/1
S2(config-if)# switchport trunk allowed vlan remove 2
S2(config-if)# switchport trunk allowed vlan add 20

c. Can PC-A ping PC-C? _____ Yes

Note: It may be necessary to disable the PC firewall to ping between PCs.

Reflection

  1. Why is a correctly configured trunk port critical in a multi-VLAN environment? ____________________
    An 802.1Q trunk port allows for transmission of multiple VLANs across one link. An incorrectly configured trunk port can prevent VLANs from communicating across switches.
  2. Why would a network administrator limit traffic for specific VLANs on a trunk port? ____________________
    To prevent unwanted VLAN traffic from traveling through that trunk port.

Device Configs

Instructor Note: The VLANs configured do not display in the running configuration but are stored in the vlan.dat file.

S1# show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Gi0/1, Gi0/2
10   Students                         active    Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                Fa0/11, Fa0/12
20   Faculty                          active    Fa0/6, Fa0/13, Fa0/14, Fa0/15
                                                Fa0/16, Fa0/17, Fa0/18
30   Guest                            active    Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                Fa0/23, Fa0/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

S1#show run
Building configuration...

Current configuration : 3966 bytes
!
version 15.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname S1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Hf8a$8iwF0hp1dYGtxw1UsJuE5/
!
no aaa new-model
system mtu routing 1500
!
!
no ip domain-lookup
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport mode access
shutdown
!
interface FastEthernet0/3
switchport mode access
shutdown
!
interface FastEthernet0/4
switchport mode access
shutdown
!
interface FastEthernet0/5
switchport mode access
shutdown
!
interface FastEthernet0/6
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 10
switchport mode access
shutdown
!
interface FastEthernet0/8
switchport access vlan 10
switchport mode access
shutdown
!
interface FastEthernet0/9
switchport access vlan 10
switchport mode access
shutdown
!
interface FastEthernet0/10
switchport access vlan 10
switchport mode access
shutdown
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
shutdown
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
shutdown
!
interface FastEthernet0/13
switchport access vlan 20
switchport mode access
shutdown
!
interface FastEthernet0/14
switchport access vlan 20
switchport mode access
shutdown
!
interface FastEthernet0/15
switchport access vlan 20
switchport mode access
shutdown
!
interface FastEthernet0/16
switchport access vlan 20
switchport mode access
shutdown
!
interface FastEthernet0/17
switchport access vlan 20
switchport mode access
shutdown
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
shutdown
!
interface FastEthernet0/19
switchport access vlan 30
switchport mode access
shutdown
!
interface FastEthernet0/20
switchport access vlan 30
switchport mode access
shutdown
!
interface FastEthernet0/21
switchport access vlan 30
switchport mode access
shutdown
!
interface FastEthernet0/22
switchport access vlan 30
switchport mode access
shutdown
!
interface FastEthernet0/23
switchport access vlan 30
switchport mode access
shutdown
!
interface FastEthernet0/24
switchport access vlan 30
switchport mode access
shutdown
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.1.2 255.255.255.0
no ip route-cache
!
ip http server
ip http secure-server
logging esm config
!
line con 0
password cisco
logging synchronous
login
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
end
S2# show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Gi0/1, Gi0/2
10   Students                         active    Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12
20   Faculty                          active    Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18
30   Guest                            active    Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                Fa0/23, Fa0/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
S2# show run
Building configuration...
Current configuration : 3966 bytes
!
! Last configuration change at 00:07:17 UTC Mon Mar 1 1993
!
version 15.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname S2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$T7f6$AYijjsmnLmWzgIAET.DDj/
!
no aaa new-model
system mtu routing 1500
!
!
no ip domain-lookup
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface FastEthernet0/1
switchport trunk allowed vlan 1,10,20,30
switchport mode trunk
!
interface FastEthernet0/2
switchport mode access
shutdown
!
interface FastEthernet0/3
switchport mode access
shutdown
!
interface FastEthernet0/4
switchport mode access
shutdown
!
interface FastEthernet0/5
switchport mode access
shutdown
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
shutdown
!
interface FastEthernet0/7
switchport access vlan 10
switchport mode access
shutdown
!
interface FastEthernet0/8
switchport access vlan 10
switchport mode access
shutdown
!
interface FastEthernet0/9
switchport access vlan 10
switchport mode access
shutdown
!
interface FastEthernet0/10
switchport access vlan 10
switchport mode access
shutdown
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
shutdown
!
interface FastEthernet0/13
switchport access vlan 20
switchport mode access
shutdown
!
interface FastEthernet0/14
switchport access vlan 20
switchport mode access
shutdown
!
interface FastEthernet0/15
switchport access vlan 20
switchport mode access
shutdown
!
interface FastEthernet0/16
switchport access vlan 20
switchport mode access
shutdown
!
interface FastEthernet0/17
switchport access vlan 20
switchport mode access
shutdown
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 30
switchport mode access
shutdown
!
interface FastEthernet0/20
switchport access vlan 30
switchport mode access
shutdown
!
interface FastEthernet0/21
switchport access vlan 30
switchport mode access
shutdown
!
interface FastEthernet0/22
switchport access vlan 30
switchport mode access
shutdown
!
interface FastEthernet0/23
switchport access vlan 30
switchport mode access
shutdown
!
interface FastEthernet0/24
switchport access vlan 30
switchport mode access
shutdown
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.1.3 255.255.255.0
no ip route-cache
!
ip http server
ip http secure-server
logging esm config
!
line con 0
password cisco
logging synchronous
login
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
end

#buttons=(Accept !) #days=(20)

Our website uses cookies to enhance your experience. Learn More
Accept !